1.

GD32 Embedded Builder User Manual

Introduction

1.1. Supported operating systems

1.2. Installation

1.3. Launch

Creating and importing project

2.1. Creating project
2.1.1. Creating a GD project

2.1.1.1. Graphical Configuration
2.1.1.2. Code Generation

2.1.2. Creating a C project

2.2. Importing project
2.2.1. Importing a GD project
2.2.2. Importing a C project
2.2.3. Importing a GNU project
2.2.4. Importing a MDKS5 project
2.2.5. Importing a IAR project

Building project

3.1. Framework of Project

3.2. Build Configuration

3.3. Toolchain Configuration

3.4. Modify Toolchain

3.5. Headless build
3.5.1. Windows platform
3.5.2. Linux platform

Debugging and Running Project

4.1. Creating a Debug/Run Configuration

4.2. Editing the Debug/Run Configuration

4.3. Debugging/Running

4.4, Resetting during Debugging

4.5. Download & Erase

4.6. Peripherals View

4.7. Live Expressions View

4.8. RTT Console View

FAQs

5.1 Building

5.2 Debugging

5.3 Platform

Revision history

No. 1/44


af://n3

GD32 Embedded Builder User Manual

1. Introduction

GD32 Embedded Builder stands as an intricately crafted C-language integrated
development environment (IDE) rooted in the Eclipse platform. It serves as an exceptional
embedded software development platform based on the RISC-V and ARM® Cortex
processor architectures.

The objective of this document is to provide guidance on the utilization of GD32 Embedded
Builder. It offers functionalities encompassing project creation, graphical MCU
configuration, and project debugging.

1.1. Supported operating systems

Component Windows Linux
PlatForm Windows 10, Windows 11 Ubuntu 22.04.2 LTS
Minimum Memory 4GB 8GB

Note: Linux systems require at least 8GB of memory.

1.2. Installation

GD32 Embedded Builder is a software based on Eclipse and Java platform. To facilitate its
utilization, if GD32 Embedded Builder version is earlier than 1.4.1.23782 (excluding 1.4.1.23782),
please ensure that the Java Development Kit (JDK) version 1.8 is successfully installed and
configured on your computer in advance.

GD32 Embedded Builder is a green and portable software that operates without the need for
installation.

1.3. Launch

Click the GD32EmbeddedBuilder.exe executable file in the Eclipse package provided by
GigaDevice to start the software.
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E workspace - GD32EmbeddedBuilder - X
File Edit Navigate Search Project Window Help
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& [0 GD32EmbeddedBuilder Welcome X |
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0 0
1 Introduction of GD32 Embedded Builder 1
i i [
D, Create GD Project 1 GD32 Embedded Builder provides a C integrated development 1
: environment based on the Eclipse platform. And it has the following : DemoSuites [FirmwareLibrary
I functions: I GD32A503 GD32C103xx
2 Import Projects 1 1. Project Creation 1 GD32C113xx GD32E103x¢
1 Chip ion & Aut tic Initialization Code 1 GD32E113xx GD32E230xx
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GD32E507xx GD32E508xx
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GD32 Embedded -
i Builder User Manual 1 3. Project Debugging 1 GD32F205xx GD32F207xx
1 S B B 1 GD32F303%x GD32F305%X
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I I GD32F403xx. ‘GD32F405xx
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The Beginning of an
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2. Creating and importing project

2.1. Creating project
2.1.1. Creating a GD project

1) Navigate to File > New > Other > GD Project > GD32 Project within the menu commands, or
Create GD32 Project on the Welcome page to start the new project wizard. Click the Next
button to continue.

[ select a wizard O >
Select a wizard —_—
Wizards:

type filter text |

» = General
b= CJC++
w = GO Project
[ GD32 C++ Project
[} GD32 C Project
[V GD32 Project
[f}] GD32 Project from an Existing GD32 Configuration File {.gdc)
¥ = Java
> = Launch Targets
» = Maven

® = Back Mext = Finish Cancel

2) Input a designated name into the Project Name field, then proceed by clicking the Next
button.
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[ NEW GD Project O X
New GD Project
Please input GD Project Name
Project Name |GD32E230
Use default location
Project Path | Di/Embedded Builder browse...
@ < Back Finish Cancel
3) Select arequired device from the Device list, then click Finish button.
[ NEW GD Project m] ®
New GD Project
Please select the targst
Series: ALL Package: ALL ~ Core: ALL -
Flash = ALL RAM == ALL - 10== ALL v
Mcu Series Package Core Flash Ram 0 ~
GD32E230F4P6 GD32E230 TSSOP2D cortex-m23 16 4 15
GD3I2E230FGPE GD32E230 TSSOP2D cortex-m23 EE 6 15
GD32E230FEPE GD32E230 TssOP20 cortex-m23 64 ) 15
GD32E230F4VE GD32E230 LGAZD cortex-m23 16 4 15
GD32E230F6VE GD32E230 LGA20 cortex-m23 32 6 15
GD32E230FEVE GD32E230 LGAZD cortex-m323 54 8 15
GD32E230G4US GD32E230 QFNZ8 cortex-m23 16 4 23
GD32E230G6U6 GD32E230 QFNZE cortex-m23 32 6 23
GD32E230GBUG GD32E230 QFN28 cortex-m23 64 ] 23
GD32E220KAUG GD32E230 QFN32 cortex-m23 16 4 27
GD32E230KEUG GD32E230 QFN32 cortex-m23 32 6 27
GD32E230KBUG GD32E230 QFN32 cortex-m23 64 8 27
GD32E230KATE GD32E230 LOFP32 cortex-m23 16 4 25
GD32E230K6TE GD32E230 LOFP32 cortex-m23 32 6 25
GD32E230KATE GD32E230 LOFP32 cortex-m23 64 8 25
| GD32E230CATE GD32E230 LGFP48 cortex-m23 6 4 39
GD32E220C6TH GD32E230 LOFP48 cortex-m23 22 6 39
GD32E230CETH GD32E230 LOFP48 cortex-m23 64 ) 39
GD32F310F4P6 GD32F310 TssoP20 cortex-md 16 4 15
GD32F310FEPG GD32F310 Tss0P20 cortex-md 32 6 15
GD32F310FBP6 GD32F310 TSS0P20 cortex-m4 64 a8 15
GD32F310GBUG GD32F310 QFNZE cortex-md 64 8 23
GD32F310KBUG GD32F310 QFN32 cortex-md 64 ] 27
L4
@ < Back Next » Cancel
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2.1.1.1. Graphical Configuration

GD32 Embedded Builder provides automatic pin function assignment, clock parameter
configuration, peripheral information configuration, code preview and project manager
configuration.

B workspace - E230CaTo/E230CHTo gac - GD32EmbededBuder - o X
file Edit Source Refactor Navigate Search Project Run Window Help

O-EB@l4 -k RCiH-B-E-C-it-0iROIGRCD O MIEEE Q ® nE
[ Project Explorer X § = 0 |[Q e230c8T6.9dc X = a|Eo x|@s[= 1~
> &5 E230C8T6

Pinout  Clock i i j Code Preview

AZ Group There is ne

Modules GD3zEZNCETS DO B B G  seen Function sue ||| thetprovides

TIMERO
TIMER2
TIMERS

TIMER13

TIMER14

TIMER15

TImMEDAR

22 Problems | &) Tasks [© Console X | [Tl Properties | 5 Progress| v B2 -N-=0

No consoles to display at this time.

& ]

Users can customize the peripheral functions according to your specific requirements. The pin
assignment function can be operated intelligently, providing both automatic and manual pin
assignment support.

The color of pins represents different meanings. Blue represents non-configurable pins. Gray
represents configurable pins. Green represents the pins associated with the pinout function,
which support automatic and manual assignment. Yellow represents the pins that are not
associated with the pinout function and only support manual assignment.

- - a8 x
File Edit Source Refactor Navigate Search Project Run Window Help
N-EHRIS -k B it dg | CiE-&-E-F-H-0-R20® CD D | MiEEE Q g @
15 Project Explorer X | ) & = 0 |[T ezsceTogde X = 8|fEo x|@8| - 0|
> & E230C8T6 Pinout  Clock Configuration ~ Configuration  Project Manager ~ Code Preview
There is no active editor
CENm, Sroup | @iwo somEmcss D O ) @) B e Functon sute || % revide anatine
ADC 2Nt
CRC IIN2
cmp N3
DBG IN4
FWDGT IN5
12co IN6
12¢1 IN7
1250 N8
IFRP e
Pl

Temperature Sensor
Internal Reference Voltage

External Signal Trigger  Disable v

TIMERO
TIMER2
TIMERS
TIMER13
TIMER14
TIMER15

TImMED AR

Auto Select ) Manu Select 0 Power Pin Analog Mode W7

21 Problems | Tasks B Console X | [l Properties| 5 Progress v8-8-=0
No consoles to display at this time.

& ]

Pink indicates that the pin can be configured for multiple functions at the same time.
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o
oln|lo|le|Elx|lw|lwl|=s|x|L|=
}}n_n_%n_n_n_n_n_n_n_

VBAT
PC13
PC14
PC15

GPIO_Analog | PAD
H {10)-PAD

F Reset state
GPIO _Input
GPIO_Qutput
GPIO_Analog
EXTIO
USARTO_CTS
TIMER1_CHO
TIMER1_ETI
CMPO_OUT
TSI_G0_IO0
+ ADC_INO

+ CMPO_IMG
RTC_TAMP1
WEKUPO

FAR
PAT
FEO
FEB1
FB2
FE10
FE11
WSS
OO

PF7
PF6
PA13
PA12
PA11
PA10
PA9
PA8
PB15
PB14
PB13
PB12

GD32 Embedded Builder presents the initial clock configuration, enabling users to manually
adjust the clock parameters as needed.

> 5 E230C8T6

8%

File Edit Source Refactor Navigate Search Project Run Window Help
C-BE@4 | e @ it R CE-E-E-Cik-0iROS LD |MEEE

7 & = 0O | e2s08T60de X

5 Project Explorer X

Pinout  Clock Configuration  Configuration  Project Manager ~ Code Preview

B & O s

(@ hardware)

CK_i2s CK_I2S(M...

FuC To12s) ¢
- cKpmcL..

sesia e e G .

HCLK(MHz)

CK_IRCEM * HOLK =
AHB enabl ;
RCEMMHZ) PLLSELD.. 6 enadle (10 AHB bus,Cortex-M23, SRAM DMA)
CK_PLLMM.. CK_SYS(M.. | AHBPRE.  CK_AHB.. CKCST_.. CK_CST CK_CSTOM..
0 —e—u2 X
— e 8 no v—s s 1
00 Cortex 123 SySTick)
CK_FCLK(..
FOLK .
PLLSEL e, U0 clock)
HXTAL(MH... PREDEV(M... - CK_TIMER..
- CK_TIMERx
80— vH 8
APBIPSC(.. TIMERx 10TMER25.13
onablo
—n -
PCLK(MH..
POLKI
HXTAL DL..
to APB1 peripherals
LXTAL(KHZ) - CK_RTC(M. Peripheral enable
CK_RTC
2768 004 TIMERO_DL.. CK_TIMER..
(0RTC)
—= 8
PR
[ Problems | & Tasks [ Console X | L] Properties | & Progress ~B0-8-- 0
No consoles to display a this ime.
&
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GD32 Embedded Builder facilitates configuration of peripheral modules, allowing users to
customize peripheral parameters. It encompasses the setup of NVIC, DMA and GPIO parameters.

[ workspace - E230CBT6/E230CET6 gde - GD32EmbeddedBulder

i Source igate Search Project Run Window Help

File
C-E@S | mieo @ it

RCA-S-E-C-ik~-0-iR@IBERICI D |HHEEE

- o9 X

Qg e@E

5 Project Explorer x| 1% 7 § = O |0 E23008T6.99c X

=o x|@8| = B

> & E230C8T8 Pinout  Clock Configuration ~ Configuration Project Manager ~ Code Preview

—General—
DMA

——Analog—
ADC

There is no active editor
that provides an outline.

[2] Problems | ] Tasks [ Console X | [l Propertes | o Progress

~8-8-=08

No consoles to display at this time.

&
ADC *
ADC  NVIC Settings ~ DMA Settings ~ GPIO Settings
Analog to digital converter Parameter

Common Settings
Data Alignment Right alignment -
Scan Mode Disable -
ADC Resolution 12bit -
Oversample mode Disable -

Regular Channel Groups Settings
Regular Channel Group Length 0 v
Continuous Mode Disable
Discontinuous Mode Disable
Number of conversions in discontinuous mode 1
Regular Channel External Trigger Select Software Trigger | |

Inserted Channel Groups Settings
Inserted Channel Group Length 1] -
Inserted Channel External Trigger Select Software Trigger
Inserted Conversion Mode MNone

Analog Watch Dog Settings
Analog Watchdog Enable Disable | |

Restare Apply oK Cancel
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ADC X
ADC  NVIC Settings  DMA Settings  GPIO Settings
DMA Request Channel Direction Priority
ADC DMA_CHO Peripheral To Memory Low
Delete Add
DMA Request Settings
Src Memory Dst Memory
Mode Normal ~ Increment Address
Data Width Byte | Byte ~
Apply oK Cancel

GD32 Embedded Builder provides code generation management functionality, allowing users to
decide, based on their needs, which files are overwritten as initial files during code generation.

File Edit Source Refactor Navigate Search Project Rum Window Help
I | & - |ex e B it 2 Cig-8-E-C-ik-0-MBIOIO-D | Q iE| %@
(& Project Explorer X 2 %, 7 § = O |0 6D32€230gde X |

=0
& GD32€230 Pinout | Clock C ion | ion | Code Preview | Proj 1
File Update Rules
Code Generator Overwrite the following files when generating code.
7] Overwrite the firmware library.

(] Overwrite the Id file.

[ Overwrite the startup file.

(] Overwrite the cfg file.

[£] Problems | & Tasks B Console X | [ Properties 4 Search!

#~E@-m-=8
No consoles to display at this time.

GD32 Embedded Builder provides a code preview feature, allowing users to view the differences
between pre-generated code based on current project configurations and existing project code.
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Fle Edit Source Refactor Navigate Search Project Run Window Help

C-ERS e it NCiIE-E-B-@-i%-0-iROIGBCIE -~ |AiE=E
& Project Explorer X | ©1 % 7 £ = O |[[€) *E230C8T6.gde X =8
v & E230C8T6 Pinout  Clock i i i
> @ Includes There s no active editor
> €8 firmware Expand All Collapse All gd32e23x hal inith X that provides an outline.
> (3 gec_startup &5 New
> @i P (/] Side by side diff O Added Code Ml Deleted Code Ml Modified Code Difference Statistics(8): Added(8) Deleted(0) Modified(0) Previous difference Next difference
X inc
:g"*“““'z o B gd32e23x hal inith old File New File
openocd gdlin (5] gd32e23x hal ith hal_gpio_init(GPI0A, GPIOPINL, Lepio_init parameter) 204 hal_gpio_init(GPI04, GPIOPINL, Lepio_init parameter
> @ src i
(B gd32e23x hal libopth
[©) £230C8T6.gdc
[3 gd3ze23x libopth epio_init_paraseter. mode = HAL GPIO_WODE_ANALOG: epio_init_parameter.mode = HAL GPIO_WODE_ANALOG:

=23
& gd32¢23 hal nitc

epio_init_paraseter. pull = HAL_GPI0_PULL_NONE. epio_init_parameter. pull = HAL GPTO_PULL_NONE

4 gd32e23x hal ite gpio_init_parameter. ospeed = HAL_GPI0_OSPEED_50! 248 gpio_init_parameter. ospee HAL_GPT0_OSPEED_50MHZ
B maine epio_init_paraeter. af = HAL GPI0_AF_0 209 epio_init_paraneter. af = HAL GPI0_AF_0
250 hal_gpio_init(GPI0A, GPIO_PIN 6, tgpio_init parameter):
epio_init_paraneter. node = HAL_GPT0_MODE_ANALOG:
gpio_init_parameter.pull = HAL_GPI0_PULL_NONE:
epio_init_paraneter. ospeed = HAL_GPT0_OSPEED_S0MIZ:
epio_init_parameter.af = HAL_GPI0_AF_(
hal_gpio_init(GPI0A, GPIO_PIN_0, kgpio_init_parameter) hal_gpio_init(GPI0A, GPIO_PIN_O, ©0_init_parameter
hal_ade_struct_init(HAL_ADC_DEV_STRUCT, kadc_info) 258 hal_ade_struct_init(HAL_ADC_DEV_STRUCT, tadc_info)

259 hal_ade_struct_init (HAL_ADC_INIT_STRICT, Eade_init_parameter 259 hal_ade_struct_init (AL ADC_INIT_STRUCT, Eade_init pasameter):
adc_init_parameter. resolution_select = ADC_RESOLUTION_12B: 260 ade_init_parameter. resolution_select = ADC_RESOLUTION_12B:
ade_init_parameter. data_alignment = ADC_DATAALIGN_RIGHT: 261 adc_init_parameter. data_alignment = ADC_DATAALIGN_RIGHT:
adc_init_parameter. scan_mode = DISABLE adc_init_parameter. scan_mode = DISABLE:
adc_init_parameter. oversample_config. oversample mode DISABLE adc_init_parameter. oversample_config. oversample mode = DISABLE

24

265 hal_adc_init (kade_info, &adc_init_parameter) hal_adc_init(tade_info, kadec_init_parameter)
hal_adc_calibration (tade_info) hal_ade_calibration(tade_info)

/¥ user code [ade_init local 1] begin %/ 268 /¥ user code [ade_init local 1] begin %/
269

270 /* user code [adc_init local 1] end */ 270 /* user code [adc_init local 1] end */

271 } 271}

[ Problems | & Tasks [ Console x | [ Properties| 53 Progress #B-m-=0

No consoles to display at this time.

2.1.1.2. Code Generation

To initiate code generation, double-click the gdc file and navigate to Project > Generate Code
within the menu. Upon successful code generation, GD32 Embedded Builder will display a
confirmation prompt.

= — o x
Flle Edit Source Refactor Navigate Search Project Run Window Help
o~ | & - | e 1o 2l @ it &2 Open Proj H-0~ QD @ E LD G| ik QB
S ProjectExplorer x| =15 7 £ = B oje ElE X|@8| = O
v E230C8T6 s Build All Cl+B  onfiguration  Project Manager  Code Preview
> 42 Binaries Build Configurations 5 There is ne active editor
> i Includes project (GD32E230C8T6 @ that provides an outline.
B) @ seaen Function sute
> @ firmware Build Working Set > LQFP48 /® ,@ m m
> @ gec_startup. e
>3 -
& iscripte ~ Build Automatically
> €8 openocd_gdink Build Targets >
> 8 sre
> & GD ARM MCU Debug SiCerlndex
€ £230C8T6.gde
Clear
2 Update Maven Project  Alt+F5
Properties
'
1250 -
IFRP e
SPI0
Temperature Sensor
sPi
Internal Reference Voltage
RCU
External Signal Trigger | Disable o ADC_INO [ PAD |
RTC ADC_IN1
TIMERO ADC_IN2 | PA2
TIMER2 2lz :
TIMERS L
TIMER13 EE S
[=) <
TIMER14 Fog
5
TIMER15 °
TIMER16
USARTO
USART1
Auto Select () Manu Select © Power Pin Analog Mode W7
wneT
[22 Problems & Tasks [ @ Console | [ Properties| =g Progress. X0 B FE-&EI#rE-8-=0
CDT Build Console [E230C8T6]
11:36:53 Build Finisned. 0 srzors, O warnings. (cook S5zms)
« »
& ]
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B mbeddedBuider )
Fle dit S avigste Search Project Run Window Help
o~ |8 - |es ket =} N CiE-E-E-G-H-0-i0I® Co-miEEE Qs e
L Project Explorer X 8637 & B |[[€) e230c8T6.gdc X =08|Eo x|®@s =0
v & E230cBT6 Pinout  Clock ion  C Code Preview
i There is no active editor
AZ  Group  No " =
Modules - comE0csTs B O Gy ) B sewen Function sute || et providesan outine
o
ADC
> [7)IN2
> €8 Idscripts CRC
> € openocd gdlink CcMP IN3
> @ src INg
> (= GD ARM MCU Debug DBG
Q) £2308T6.gde FWDGT IN5
12C0 [ZIN§ p‘g"a
12¢1 N7 :pcm
1250 PC15
N8
IFRP B
IN9 Pr1 |
SPI0
Temperature Sensor NESTH
SPIt VSsA
cu Internal Reference Voltage VDDA
" N . ADC_INO | PAD
RTC External Signal Trigger | Disable v prog
TIMERO Apc_in | PA2 |
TIMER2
TIMERS
TIMER13 E
TIMER14 e
TIMER15 ©o
TIMER16
USARTO
USART1
Auto Select ' Manu Select ©* Power Pin Analog Mode W97
(22 Problems | Tasks [B Console X | (] Properties| 5 Progress X soGEE-&E®ra-0--0
CDT Build Console [E230C8T6]
11:36:53 Busld Finished. 0 errors, 0 warnings. (took S82ms)
“ >
& ]

2.1.2. Creating a C project

1)
new project wizard, Click Next.

Navigate to File > New > Other > GD Project > GD32 C Project menu command to start the

[ select a wizard

Select a wizard

Wizards:

type filter text

» = General

b= CJC++

w = GO Project
[ GD32 C++ Project
(i) GD32 C Project
[Mi] GD32 Project

» = lava
» = Launch Targets

» = Maven

[fi] GD32 Project from an Existing GD32 Configuration File (.gdc)

©)

= Back

MNext = Finish Cancel

2)

Select to create GigaDevice ARM C Project or GigaDevice RISC-V C Project, and the

compilation chain on the right will automatically associate with GD ARM MCU Toolchain or GD
RISC-V MCU Toolchain. Then, enter a name in Project name field, Click Next.
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[} C Project

C Project

Create C project of selected type

Project name: [GD32E230

Use default location

& Empty Project
& GigaDevice ARM C Project
@ GigaDevice RISC-V C Project
& Hello Waorld ANSI C Project
» = Shared Library
> = Static Library
» = Makefile project

Location: | Di\eclipse-rcp-2023-12-workspace\runtime-rcpprotest: Browse...
Project type: Toolchains:
¥ (= Executable GD ARM MCU Toolchain

Show project types and toolchains only if they are supported on the platform

® = Back Mext =

Finish

Cancel

Select a required device from the Device list, click Finish.
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[ C Project O
Target processor settings
Select the target processor family and define flash and RAM sizes.
Device Description
GD32E230K4UB Description
GD32E230KBUB Description
GD32E230KBUB Description
GD32E230K4TH Description
GD32E230K6TE Description
GD32E230KBTE Description
GD32E230C4ATE Description
GD32E230C6T6 Description
£ ]
Flash size(kB) 16 |
RAM size(kB) |4 |
Code location | FLASH w |
Floating point unit
Check sorme warnings
Check most warnings
Enable -Werror
Use -0g on debug
Use newlib nano
Exclude unused
Use link optimization
® = Back ” Mext = | | Finish | ‘ Cancel
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[ meddes buider - Go32E230/arc/mainc - Embedded Bulder

-

&5~

File Edit Source Refactor Navigate Search Project Window Help
@l ea@&itic

3 31~ 51 - ¢

[ m

X

&

&, Project Explorer 5%
V& 03230
) Includes
> & firmuare
> @ ine
> & ldscripts
Ve
> [ gd32e230k startc
[@ gd32e23xitc
> &) maine
> [@ systicke
2] readme.xt
openocd gdlinkclg

& Outine 23
U gd3ze23ch
U gd32e230k starth
U systickh
o stdioh
o main(void) : int

EARY o% v=0

B% v=0O

\file
\or. running LED

\version 2019-02-19, V1.0.0, Firmuare f

Copyright (c) 2019, Gigabevice Semiconductor Inc

ALL rights reserved.

5 ource code must retain the ab
1 ions and the following disclaimer.
2. Redistributions in binary form must repro
« s

ND CONTRIBUTORS
ITED TO, T

Suc DA

#include "gd32e23x.h"
#include "gd32e230k_start.h"
#include "systick.h"
#include <stdio.h>

& Tasks|[2) Problems | & Console £ | ® Build Targets

No consoles to display at this fime.

a5 15"

HE TWPLIED
CLATMED.

=8|

#B-0--08

o

Writable Smart Insert | 1:1

2.2. Importing project

2.2.1. Importing a GD project

1) There are two ways to select this feature.

Navigate to File > New > Other > GD32 Project from an Existing GD32 Configuration File(.gdc)
within the menu commands, or Select File > Import, In the popup window, choose General >
GD32 Project from an Existing GD32 Configuration File(.gdc) and click Next. Click the Next
button to continue.

Thew Al+ShifRt+N > | B New project O X | [ 632 Project from an Existing GD32 Configuration File (.gde) o x
Open File... 3
€ Open Projects from File System.. Select a wizard == <> | GD32 Project from an Existing GD32 Configuration File (.gdc)
Recent Files » / Empty GD32 file (.gde) is not
Close Editor Cerl+W
Close All Editors Ctrl+ShifteW | Wizards: GD32 gdc file
cutes | [ope fer et File: | e
&) Save As.. > = General )
s Project
Save All Ctrl+Shift+S v C/CHE
Revert C/C++ Project Project Name:
Move, C++ Project Use default location
S
Rename 2 C Project Location: Di/EclipsePraject 2023/runtime-rcpprotest-Windows.product | |BIONEER
) Makefile Project with Existing Code
§) Refresh s i ¢
&) Refres
= (= GD Project
rt ite > . Py . .
onvert bine Delimiters To 2 [@) D32 Project from an Existing GD32 Canfiguration File (gdd)
& Print.. Crl+p [@ GD Project
2 Import... > & Java
i Export
Properties Alt+Enter
Switch Workspace >
Restart @ < Back Net ~ Finish Cancel @ Next > Finish Cancel
Exit
New > | [ Import [u] X | [ GD32 Project from an Existing GD32 Configuration File (.gdc) o X
3
roject from an Existin nfiguration File (.
&= Select " GD32 Project f Existing GD32 Configuration File (gdc)
Show | Ale+shift+ W > .
o In ! [Z285] | empty D32 conf fle (gde) is not supported
Open With >
Show in Local Terminal >
Select an import wizard: GD32 .gdc file
[ Copy cirl+C ‘
B \type Filter text File: Browse...
Paste Crl+v
9 Delete Delete v (= General Q Project
& Archive File )
Source > A . Project Name:
astin rojects into Workspace
" Existing Proj Worksp
Ve £3 File System Use default location
Rename... 2
2 (@ D32 Project from an Existing GD32 Configuration File (gdc) Location: Di/EclipseProject_2023/runtime-repprotest-Windows.product | | Browse...
rase roject into Worl ace
E 1AR Project into WorkSp
@ Download A MDKS Project into WorkSpace
3 import.. (] Preferences
4 Export (3 Projects from Folder or Archive
> B ClCHr
SilRcf=sh = > 2 Install
Index s | | > = Maven 5
Resource Configurations >
Team >
Compare With >
Replace With >
| @ < Back Nest = Finish Cancel @ < Back Next » Finish Cancel
Properties Alt+Enter
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2) Select the GD project file. Click the "Browse" button and choose the GD project file with the
.gdc extension. By default, the project name from the GD file will be used, but you can change the
project name as needed. (There cannot be projects with duplicate names in the workspace; if
there are duplicate names, you will need to change the project name.) In addition, you can modify
the save path for the GD project file. Click Finish to proceed with the project conversion.

[i] GD32 Project from an Existing GD32 Configuration File (.gdc) O x

GD32 Project from an Existing GD32 Configuration File (.gdc)

{1, Directory with specified name already exists

G032 .gdc file
File: |C:‘l..lc arege L resltop\E23X0E23X.gdc Browse...

Project

Project Mame: |E23X
Use default location

Location: [:/EclipseProject 2023 /runtime-rcpprotest-Windows.product | | Browse...

® = Back Mext = Finish Cancel
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[i] GD32 Project from an Existing GD32 Configuration File (.gdc) O x

GD32 Project from an Existing GD32 Configuration File (.gdc)

(1, Directory with specified name already exists

G032 .gdc file
File: |C:‘I..I ohsly By TPl to p\E23X\E23X.gdc Browse...

Project

Project Name: | E23x

[ ]Use default location

Location: | D\ softwarel Browse...

® = Back Mext = Finish Cancel

2.2.2. Importing a C project

There are two ways to select this feature.
* One way to open the Import dialog is to use the menu [File]>[Import...]
* Another way is to right-click the Project Explorer view and select [Import...]
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[ Import O et
Select \“
Create new projects from an archive file or directory. H

Select an import wizard:

type filter text

w [= General
& Archive File
|L§ Existing Projects into Workspace
7} File System
[Mi] GD32 Project from an Existing GD32 Configuration File (.gdc)
& AR Project into WorkSpace
MDKS Project into WorkSpace
] Preferences
[} Projects from Folder or Archive

® = Back Meaxt = Finish Cancel
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Y import O x
Import Projects =
Select a directory to search for existing Eclipse projects. /4
0 Select root directory: | D\Workspace\IDE\runtime-rcpprotest-Windows.producty, 303 e Browse...
() select archive file: Browse...
Projects:
B 303 (D\Workspace\|DEyruntime-rcpprotest-Windows. product! 303) Select All
Deselect All
Refresh
Options
[CIsearch for nested projects
[l Copy projects into workspace
[[IClose newly imported projects upon completion
[CIHide projects that already exist in the workspace
Working sets
[() Add project to working sets Mew...
Warking sets: Select...
® = Back Mext = Cancel

2.2.3. Importing a GNU project

1)  Right-click in the Project Explorer view of C/C++ perspective to select Migrate to GD

Project wizard.

bidee Builire

Search Projsct fun Window e

S E G @i il Q@I G
B % 7T O | 6ndEads

™ »

et

5 Praject Explorer i
» B any

Cpenin tesw Window

B Copy ctec
Baste ey

K Deimne Driate
Sou »

£ B
@ Dovnkud
=
e Epon.
Duild Prejact
Clean Project
1 Rebresh
Closm Broject

Index

Bur &3
Debug Az
Brafile £s >
Team

Campare With »
Restors fram Locs History-

# O

o, A sFrsar

Descriphion . Resource  Path Lacation

EH

& apazez3
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Select the file with the suffix “cproject” of the GNU project which you want to convert. Click

Finish button to start the conversion process. If the conversion is successful, you can import and

build the GNU project as usual.
B Select root directory — O et
D:\GDEEEmbeddedEuiIder\GDEEEEEﬂ\.cpr::rjecli Browse
Migrate Cancel

2.2.4. Importing a MDK5 project

1)

Select Window > Show View > Other. In the popup window, choose Console. This will bring

up the console to display outputs during the conversion process. (If the console is already open,

you can skip this step.)

Window Help @ Show View m] X
New Window v A == = =7 al |type filter text
Editor > ? § = B8 ’ ‘ v (= General A
Bookmarks
Appearance > | ‘ I—_g Concole| ]
F @ Internal Web Browser
Show View > [l Bookmarks 0 Markers
Perspective > B= Outline Alt+Shift+Q, O Minimap
- 83 Outline
oD . ﬂv—
Navigation 5 [#7  Problems Alt+Shift+Q, X [#) Problems
&3 Progress =g Progress
Preferences . B Project Explorer
{5 Project Explorer [ Properties
. 4 Search
[C] Properties B Tosks
v:| Tasks Ees -
&) Terminal
Other... Alt+Shift+Q, Q Cancel

2) Select File > Import, In the popup window, choose General > MDKS5 Project into
Workspace(1) and click Next. Then, select the MDKS5 project file that you need to convert.
New Alt+Shift+N > || [ import o X || @ import o X
& gpe: :Ie:n“ from File System. Select N Import MDKS Project
> R::;m F:J:S sl iy R [@ Please select a .uvproj fle for a existing MDKS project.
Close Editor Ctrl+w o D R
Close All Editors Ctrl+Shift+ W [pe r ] Import project: | | 'Browse...
Save crrl+s o Gonerl Project Name: | |
SERhE B Archive File
Save All Ctrl+Shift+S & Existing Projects into Workspace
Revert () File System
" 2 [ MDKS Project into WorkSpace
Ve [] Preferences
Reelies 2 (3 Projects from Folder or Archive
Refresh Fs > B C/C++
Convert Line Delimiters To > > (= Install
g Print. Ctrl+p ) Z ;’a";‘ebug
g Import... > & Team
/4 Export..
Properties Alt+Enter
Switch Workspace >
:’f“"" @ <Back Finish Cancel ®@ < Back Next > Finish Cancel
xit
3) Select the MDKS5 project file. Click the Browse button and choose the MDK5 project file with

the extension .uvprojx. By default, the project name from MDK5 will be used, but you can change
the project name as needed. (There cannot be projects with duplicate names in the workspace;
projects with duplicate names will need a name change.) Click Finish to proceed with the project

conversion.
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[ select a .uvprojx file hed
&« v » IHEEEE » =M » GD32F30x_Firmware Library » Template » Keil5_project v O EE"Keil5_project” o
HE v eI =~ @ @
0115 ~oER e lm il Foh
2024 SelectionGuide list 2024/7/31 17:22  SrfsE
C++EEFHES output 2024/7/31 17:22 prg =23
CppCheck RTE 2025/2/28 10:54 =
Ds k3 Project.uvprojx 2025/2/28 10:53 BEision5 Project 74 KB
GD32AllInOneProgrammer_win_V4.2.10.2818
GD32EmbeddedBuilder_v1.0.6.28461_G5x3 £
GD32EmbeddedBuilder_v1.4.12.28537
GD32F30x_Firmware_Library
Examples
Firmware
Template
IAR_praject
Keild_praoject
Keil5 project v
IFE(N): | Project.uvprojx v| *.uvprojx ~
FIFFO) i
@ import O >

Import MDKS Project

Please select a .uvprojx file for a existing MDKS project.

Import project: |C:‘ILLII.I_'_ = I N 1\Des|dop\GD32F3{lx_Firmware_Libra| Browse...

Project Name: | Project |

® = Back Next = Finish Cancel

4) After completing the conversion, create a directory named GD32_Eclipse_project one level
above the *.uvprojx project. This will organize the converted project. The files in the project are
linked to the files pointed by the *.uvprojx.
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File Edit Source Refactor Navigate Search Project Window Help

-G a2t Qicios B -fl-ove-o-|m Q ®|E
= B8

T projectbxporer x| 6% 7 £ = [ maine x|

~ G Proje

> ) Il

v @& Apy

> (@& 9d32630x ite #ifdef _FIRMARE_VERSION DEFINE
uint er = 05

Eclipse_project)

< int main(void)

> mane -
> [@ systicke

> G Cmsis

> & Dec

> @ gee_startup

> @ s

> Gz Peri

> @ Ut
2 openocd gdlink.cig

_Core);
(KEY_RAKEUP, KEY_MODE_GPI0);

er >> 16), (uints_t)(fu_ver > 8));

A E-8-=0

T outine x| B B R\ o % § = B
U gd32i0xh
o systickh
U stdioh
o mainh
U gd321307c evall

Successfully!
6032 Eclispe project is generated!
. nt) i Project path: C:\Users\! Fg§ = jJ% \Desktop\G032F30x_Firmvare_Library\Template\6D32_Eclipse project
& fputclint, FILEY : int

Writable Smart Insert 1:1:0

Note:

This import feature is only supported on Windows operating systems.

2.2.5. Importing a IAR project

1) Select Window > Show View > Other. In the popup window, choose Console. This will bring
up the console to display outputs during the conversion process. (If the console is already open,
you can skip this step.)

Window Help [ Show View o X
New Window vl v o F Py v A [type filter text |
I Editor > E § = B8 ‘ ‘ v (= General A
5 Bookmarks
Appearance > | ‘ B Console| |
F @ Internal Web Browser
Show View > [l Bookmarks B Markers
Perspective > 5= Outline Alt+Shift+Q, O Minimap
= 9= Qutline
o) . o=
Navigation 5 [#] Problems Alt+Shift+Q, X [# Problems
@ progress =B Pro'gress
Preferences - . [# Project ‘Exp[orer
iy Project Explorer [ Properties
. 4 Search
[C] Properties B Tosks
¥ Tasks Tosesl -
& Terminal
Other.. Alt+Shift+Q, Q [ open ]| concel

2) Select File > Import. In the popup window, choose General > IAR Project into
Workspace(1) and click Next. Then, select the IAR project file that you need to convert.
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New Altsshift+N > || [ Impert o % || [ import o X
Open File.
Select Import IAR Project
[ Open Projects from File System... N mpo! ol
Recent Files N EES Please select a .ewp file for an existing IAR project.
Close Editor Ctrl+W
Close All Editors Cerl+Shift+ W SRt et )
[type fiter text | Impert project: | || Browse..
Save Ctrl+S .
e 2 Existing Projects into Workspace 5 Project Name: | ]
Save Al Ctrl+shift+S £ File System
- [] GD32 Project from an Existing GD32 Configuration File (gdc)
2 & IAR Project into WorkSpace
Move... MDK3 Project into WorkSpace
Rename.. F2 [T] Preferences
& Refresh F3 ([} Projects from Folder or Archive
Convert Line Delimiters To > > = CiCe+
: > £ Install
1 Print... Ctrl+P » G Maven
o Import.. > (= Run/Debug .
i Export.
Properties Alt+Enter
Switch Workspace >
Restart @ < Back Next > Finish Cancel (@) <Back Next » Finish Cancel
Exit

3)

project name as needed. (There cannot be projects with duplicate names in the workspace;
projects with duplicate names will need a name change.) Click Finish to proceed with the project

conversion.

Select the IAR project file. Click the Browse button and choose the IAR project file with the
extension .ewp. By default, the original IAR project name will be used, but you can change the

GoEas;3
- v P <« GD32F30x_Firmware_Library ¥3.02 » Template » IAR_project v

R

User Guide &

R

ER ERHE =3

Examples

| Projectewp 2025/9/19 9:48 EWP Zz#f

Firmware
CMmSIS
GD
GD32F30x
Include
Source
ARM
IAR
GD32F30x_standard_pe
GD32F30x_usbd library
GD32F30x_usbfs_librany
Template
IAR_project
Keild_project
Keil5_project

Utilities
v

o

L EBEIAR project”
Bz~ [
Foh

81 KB

IAFE(N): | Project.ewp

v| IAR Project Files (".ewp)

b
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E Import

Import IAR Project

Please select a .ewp file for an existing |AR project.

Import project:

Project Name:

| CéFirmware Library 2025.07\GD32F30x_Firmware Li brar|

Browse...

| Project

®@

= Back MNext =

Finish

Cancel

4) After completing the conversion, create a directory named GD32_Eclipse_project one level
above the *.ewp project. This will organize the converted project. The files in the Eclipse project

are linked to the original source files referenced by the *.ewp configuration.

File Edit Source Refactor Navigate Search Project Run Window Help

> ) Includes
~ o) Application
> [& gd32030x it
> (& main.c
> [@ systicke
> G CMSIS
> G Doc
> G gee_startup
> Gy GD32F30x EVAL
> o) GD32F30x Peripherals
> G ldscripts
> &= openocd_gdlink

S Project (in GD32EBuilder_proje:

(=)< | & - |61 @ it & R CiIROIE-E-E-F ik 0 @RICY GO |k
&5 Project Explorer X = 8 |[[& mainc x|
88y & < int main(void)

#ifdef _FIRMARE_VERSTON DEFINE
uint32_t fu_ver = 0
Hendif

/* configure systick */
03

‘the LEDS, USART and key */

gd Vel con init(EVAL COr0);
gd_eval_key_init(KEY_HAKEUP, KEY_MODE_GPIO);

= print out the clock frequ
pr mtf( A sts s

f sysiem, 4D, APOL s fon2 ¢/
req_get (CK_SY5));

Tock_ muu(« a8)):

clock_freq_get(CK_APB1));

lock_freq_get(CK_APB2));

es Firmiare version: VEd.%d.%d", (uintd_t)(fu_ver >> 24), (uintd_t)(fuver >> 16), (uints_t)(fu_ver > 8));
ARE_VERSION_DEFINE */

while (1)
THCRESET == gd_eval key_state_get(KEY_WikELP)){
gd_eval_led m 03);
delay_1ns (500
gd_eval_led nff(LEDs)
gd_eval_led_toggle(LED4);
}
¥
}

#ifdef GD_ECLIPSE_GCC

/* retarget, the C library printf function to the USART, in Eclipse GCC environment */
“int _io_putchar(int ch)

{

transait(EVAL_COM, (uints_t)ch);
mk(mzr == usart_flag_get (EVAL_COM, USART_FLAG_TEE));

QA EewE
=@

[2] Problems | &) Tasks [ Console X | [l Propertes | o Progress

A E-83-=0

IAR Convert Console

Create project structur

Adding virtual folder seructure and linked file resources.
Copy Firmeare-1ib files.

Add the include path configuration.

Successfully!

G032 Eclipse project is generated!
Project path: D:\Firmware_Library_2825.07\GD32F30x_Firmare_Library_V3.0.2\Tesplate\GD32¢Builder_project

Writable

Smart Insert

Note:
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This import feature is only supported on Windows operating systems.
If the IAR workspace (*.eww) contains multiple projects, repeat the import for each required
*.ewp or import one and then add others as needed. Relative include paths and

preprocessor macros defined in IAR will be translated where possible; verify them in the
project properties after import.
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3. Building project

3.1. Framework of Project

A project is created with the default settings and a full set of configurations based on the project
type and the device you selected. C/C++ perspective is opened by default after the project is
created.

Expand the project folder to display the project framework, which includes the GD firmware,
linker file and peripheral configuration code.

|G embedded Bulder - GD32E230/src/main - Embedded Bulder - 8 x

Fle Edt Source Refactor Navgate Search Project Window Help

D-HG B #eADERCIOF - §-06 D ®|[E

15 Project Explorer 53 5% v = 0| epuesogde |8 mainc 22 =8|s

v 5 GD32E230 o=
> @)l Includes

AR~
\file main.c

> G firmware or
> Eine Copyright (c) 2023, Gigabevice Semiconductor Inc
> G Wdearipts ALL rights reserved.
v s
> [@ gd32e23x hal init<c Redistribution and use in source and binary forms, with or without modification,
) & gd32e23c halite are permitted provided that the following conditions are met
> i 1. Redistributions of source code must retain the above copyright notice, this
[€) 6D32€230.9dc List of conditions and the following disclainer.

- i 2. Redistributions in binary form must reproduce the above copyright notice,

& openocd gdlinkcly This 115t of conditions and the folloving disclaincr in she documentation
and/or other materials provided with the distribution

3. Neither the name of the copyright holder nor the names of its contributors
may be used to endorse or promote products derived from this software without
specific prior written permission

THIS SOFTUARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
OR IHPLIED WARRANTI UT NOT LIMITED T0, THE IMPLT

Tv,
u1sE)

R
SED OF THE POSSIBILITY

#include "gd32e23x_hal.h"
#include "gd3223x_hal_init.h"
/% user code [global 0] begin

/% user code [global 0] end */

main function
\paran[in] none
\paran[out] none
< int main(void)
{

/* user code [local 0] begin */ v
5= Outline 2 B 1% R © % 7 = O |[& Tasks|[2] Problems|E Console 52| ® Build Targets| #E-f-=10
o gd32e23x halh No consoles to display at this time.
o gd32e23chalinith
® main(void) : int
Writable Smort Insert [ 1:1

In the Project Explorer view, right-click the menu of the target project which includes functions of
creating a new file, building a project, opening the project properties dialog and so on.

Embedded Builder - GD32E230/src/main.c - Embedded Builder - x
File Edit Source Refactor Navigate Search Project Window Help
O -0 & AP BWCIO®S-iH-F-BG-D [auick Access] | 8 | IS
& Project Explorer 7 B % v = O |[Qocsue20gdc | @ mainc 3 = 0ls
-5 6032 or ~ o
Sgind  New S | \ile nainc
> fim]  Golnto o/t
> @ inq Copyright (c) 2023, Gigabevice Semiconductor Inc
el Open in New Window pyright (c) €
> @ s All rights reserved.
v sre| [ Copy crlsC
>B|@ paste clsv Redistribution and use in source and binary forns, with o without modification,
Y8 |% Do e are permitted provided that the following conditions are met
> @ Source > 1. Redistributions of source code must retain the above copyright notice, this
ool  following disclainer
Qe o forn musk reprotuce the above copyright notice,
S P Rename.. R nd the following disclaimer in the documentation
o rials provided with the distribution
O Erase 3. Neither the name of the copyright holder nor the names of its contributors
@ Downlosd may be used to endorse or promote products derived from this software without
Specific prior written permission
Migrate to GD Project
L g THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
= IMPL INCLUDING, BUT NOT LIMITED TO,
i Export.
Build Project
Clean Project
) Refresh s
Close Project
Close Unrelated Project %
#include "gd32e23x_hal.h"
iy et > #include "gd32e23x_ha. h
Build Targets > /* user code [global @] begin */
(s ’ /* user code [global @] end */
O Runas > d
5 Debug As > \brief  main function
Profile As > paran[in] none
\paran(out] none
Team > \cetva
Compare With > */
< int main(void)
Restore from Local History.. R
Configure > /* user code [local 8] begin */ v
Properties Alt+Enter = =
= Outline. ¥ 7 = O (& Tasks|[2] Problems | Console £ | ® Build Targets 2B N8>0
U gd2ed3chalh No consoles to display at this time.
u gd32e23x hal inith
©  main(void) : int
& aps2e230

3.2. Build Configuration
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In the project properties dialog, you can see the default settings and configurations, such as
include paths, defined symbols, the linker script file and the toolchain path. Depending on the
default settings and configurations, the project can be compiled and linked correctly.

Use the Tool Settings tab to configure the compiler and linker options.

[ Properties for GD32E230

type filter text

» Resource
~ C/C++ Build
Build Variables
Environment
Logging
Settings
Toal Chain Editor
XL C/C++ Compiler
» C/C++ General
Project Natures
Project References
Run/Debug Settings

Settings

Configuration:

GD ARM MCU Debug [ Active ]

i Tool Settings Taolchain Settings Target Settings & Build Steps

@ Target Processor
(& Optimization
# Warnings
2 Debugging
(& Output File
v i GD ARM MCU C Compiler
= General
@ Preprocessor
(# Includes
w By GD ARM MCU Linker
# General
(# Libraries
(# Miscellaneous
v 5 GD ARM MCU Assembler
@ Preprocessor
(# Miscellanecus
(# Includes

ARM Family cortex-m23
Architecture None
Instruction set Thumb
Float ABI MNone

FPU Type None

~ | | Manage Configurations...

Build Artifact Binary Parsers @ Error Parsers

¥

Other target flags

All options

-mcpu=cortex-m23 -mthumb

Restore Defaults Apply
@ Apply and Close Cancel

The Target Processor category is used to configure the compiler options related to the target

processor.

The Optimization category is used to configure various sorts of optimization options. The
Warnings category is used to configure the options to request or suppress warnings. The
Debugging category is used to configure various special options which are used for debugging.
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[ Properties for GD32E230

type filter text

> Resource
~ CfC++ Build
Build Variables
Environment
Logging
Settings
Toal Chain Editor
XL C/C++ Compiler
5 CfC++ General
Project Natures
Project References
Run/Debug Settings

Settings

Configuration: |GD ARM MCU Debug [ Active ]

&) Tool Settings Taalchain Settings Target Settings  #* Euild Steps

(2 Target Processor
(# Optimization
2 Warnings
& Debugging
(& Output File
v 3 GD ARM MCU C Compiler
# General
(# Preprocessar
# Includes
v i GD ARM MCU Linker
# General
# Libraries
2 Miscellanecus
v % GD ARM MCU Assembler
@ Preprocessor
2 Miscellanecus
 Includes

Optimization Level Level 0 (-O0)

M length (-frr length=0)
Plain char is signed (-fsigned-char)
Function sections (-ffunction-sections)
Data sections (-fdata-sections)

[ MNeo commaon unitialized (-fno-comman)
[]Position independent code (-fPIC)
[JStandard link-time optimizer (-flto)

~ | | Manage C

Build Artifact Binary Parsers @ Error Parsers

onfigurations...

Other optimization flags

All options

-00 -fmessage-length=0 -fsigned-char -ffunction-sections -fdat:

Restore Defaults

Apply

©)

Apply and Close

Cancel

The Output File category is used to output files in other formats, such as list, dump, map, hex,
bin and size file. You can enter some options in Other objcopy flags edit box to control the hex
or bin file. The Other objdump flags edit box is used to configure the list options. The Other size
flags edit box is used to enter some size options.
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[ Properties for GD32E230

type filter text

Resource
~ CfC++ Build
Build Variables
Environment
Logging
Settings
Toal Chain Editor
XL C/C++ Compiler
C/C++ General
Project Natures
Project References
Run/Debug Settings

Settings

Configuration:

¥ Tool Settings Toolchain Settings

GD ARM MCU Debug [ Active ] ~

Manage Configurations...

Target Settings  #° Build Steps Build Artifact Binary Parsers @ Error Parsers

(2 Target Processor
(& Optimization
2 Warnings
& Debugging
(# Output File
v 3 GD ARM MCU C Compiler
# General
(# Preprocessar
(2 Includes
v 3 GD ARM MCU Linker
# General
# Libraries
2 Miscellaneous
w B3 GD ARM MCU Assembler
(# Preprocessar
2 Miscellaneous
2 Includes

[ List
JDump
M Map
O Hex
] Bin
] Size

Other objcopy flags | |

Other objdump flags |--source --all-headers --demangle --line-numbers --wide |

Other size flags |--format=berke\ey |

Restore Defaults Apply
® Apply and Close Cancel

The GD ARM MCU Assembler tool is used to configure the options for the assembler.

The GD ARM MCU C Compiler tool is used to configure the options for C compiler. In the General
category, you can configure the start address and length attributes of Flash and RAM, which are
correspond to the memory configuration of the linker script file in the valid format.

3.3. Toolchain Configuration

Paths of the toolchain and build tool is the default configuration.

Select Project > Properties > C/C++ Build > Settings. In the Toolchain Settings tab, click Browse
button to choose required toolchain path and the build tool path. Then, click Apply or Apply and

Close button.
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[ Properties for GD32E230 ] ®
type filter text Settings f=10 4 - -
Resource
~ CfC++ Build
Build Variables Configuration: |GD ARM MCU Debug [ Active ] ~| | Manage Configurations...
Environment
Logging
Settings i Tool Settings Toolchain Settings  Target Settings  #* Build Steps Build Artifact Binary Parsers @ Error Parsers
Toal Chain Editor
. Toaolchain Name: | GNU Toals for ARM Embedded Processors v
XL C/C++ Compiler
C/C++ General Toolchain Prefis: |arm-none-eabi- |
Project Natures . - -
R ToolChain Path: |.\\T00\5\\GNU Tools ARM Embedded\\xpack-arm-none-eabi-gcc},9.2.1-1.1\\bin ‘ Browse
Project References
Run/Debug Settings Build Tool Path: |.\\Too\s\\Bui|d Tools\42.10-20180103-191%\bin ‘ Browse
Restore Defaults Apply
® Apply and Close Cancel

3.4. Modify Toolchain

Right click the project name, click Properties, then click Properties > C/C++ Build > Settings >
Toolchain Settings, modify the content in the Toolchain Prefix to the new toolchain prefix, then
modify the ToolChain Path to the new toolchain path, then click Apply. When debugging,
please open Debug Configuration of the debugging project, then click Apply and Debug.

3.5. Headless build
3.5.1. Windows platform

The "headless-build.bat" file under the project encapsulates some commands used for executing
the headless compilation function, allowing you to compile a specified project from the command
line without opening the graphical interface. A simple example is shown below.
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Bl C:\Windows\System32\cmd.exe - O *

html #
ion GD AFM

--line-numk

RN

If you need to use more features, you can use the "GD32EmbeddedBuilderc.exe --
launcher.suppressErrors -nosplash -application
org.eclipse.cdt.managedbuilder.core.headlessbuild -help " command to view more parameter
information.

mder URI

mder URI

3.5.2. Linux platform

In the same directory as the executable file, run the following command in the terminal interface:
"./headless-build.sh -workspace /root/eclipse/patch/headlessbuild1/eclipse/workspace -project
ARM -build"

=+ root@gdtest-virtual-machine: ~feclipse/patch/headlessbuild... Q =

root@gdtest-virtual-machine:~/eclipse/patch/headlessbuild/eclipse# ./headless-bu

ild.sh -workspace jfroot/eclipse/patch/headlessbuildl/eclipse/workspace -project
arm -butd]]
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4. Debugging and Running Project

4.1. Creating a Debug/Run Configuration

Select your target project, then click the debug configuration icon on the toolbar. Then, the Debug
Configurations dialog window will be opened.

il | @[EceI2RM CiIIV/-RETH -y~

Double-click GDB General Debugging to create a new debug launch configuration. If the
configuration is created successfully, the debugging project name will be in the Name field.

[} Debug Configurations O *

Create, manage, and run configurations

F @ x| B =~ Configure launch settings from this dialog:
type filter text - Press the 'New Configuration' button to create a configuration of the selected type.
[c] C/C++ Application - Press the 'New Prototype’ button to creat..nfiguration prototype of the selected type.

[©] C/C++ Attach to Application
[©] C/C++ Postmortem Debugger
[©] C/C++ Remote Application 2| - Press the 'Duplicate’ button to copy the selected configuration.

@ GDB General Debugging |
[©] GDB Hardware Debugging
Java Applet

O - Press the 'Export’ button to export the selected configurations.

3 - Press the 'Delete’ button to remove the selected configuration.

o - Press the 'Filter’ button to configure filtering options.

Java Application - Edit or view an existing configuration by selecting it.
1 Launch Group

= Launch Group (Deprecated)
Zl Remote Java Application - Select launch configuration(s) and then s..Prototype’ menu item to unlink a prototype.

- Select launch configuration(s) and then s..k Prototype' menu item to link a prototype.

- Select launch configuration(s) and then s.." menu item to reset with prototype values.

Configure launch perspective settings from the 'Perspectives’ preference page.

Filter matched 11 of 11 items

® Debug Close

Please make sure that the project has been built successfully.
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[@] Debug Configurations a X
Create, manage, and run configurations ﬁ\‘
CERAEXI BT~ Name: |GD32E230 GD ARM MCU Debug |
[vpe fiter text ||| (Emain] Debugger startup] svD |

[E] C/C++ Application et

[E] C/C++ Attach to Application

[E] C/C++ Postmertem Debugger [cosze230 [E s

[£] C/C++ Remote Application C/C++ Application:

v [@i) GDB General Debugging

IGD ARM MCU Debug\GD32E230.elf
[l GD32E230 GD ARM MCU Debug

[E] GDB Hardware Debugging Variables... Search Project... Browse...
Java Applet Build (if required) befare launching
Java Application
/& Launch Group Build Configuration: | Select Automatically v
7L Remote Java Application (O Enable auto build O Disable auto build

(® Use workspace settings Configure Workspace Settings...

Revert Appl
Filter matched 11 of 52 items e PRIy
®

Notice it should be terminated by clicking the red block when you stop debugging. If you don't
click it, it will have influence on the next debugging.

R ] X

& conscle 2 ‘ [ Peripherals 1I.J"iv.=.-'m.r| ?.»'& %= | =" Eﬁ == EI| i

GD32E230 GD ARM MCU Debug [GDE General Debugging] GD-Link

4.2. Editing the Debug/Run Configuration

The GDB General Debugging wizard contains four tabs as shown in the figures below. You will
use these tabs to customize your run and debug configurations. Click the Debugger tab to select
a debugger type from GD-Link. If GD-link is selected as the debugger, you should select GDB
Server between GDLinkGDBServer and Openocd. In addition, click the Scan button to read the
core ID of the target device by your selected debugger. Click the Startup tab to set debugging
options, including reset options, executable file and symbols loading, breakpoint options, etc.
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[@] Debug Configurations a X
Create, manage, and run configurations
CEPEXBY - Name: | GD32£230 GD ARM MCU Debug
[iype fiter text ||{[ B Main [Debugger] startup| svO |
[E] C/C++ Application Debugger
[E] C/C++ Attach to Application Debugger:
[€] C/C++ Postmortem Debugger
[E] C/C++ Remote Application Core ID: |0xBE12477
v [} GDB General Debugging
[ GD32E230 GD ARM MCU Debug T Eawr S5
[E] GDB Hardware Debugging 1P Address:
Java Applet R
Jov hpplection
& Launch Group Device: GD3I2EZ30CATE [ Code in RAM
@ Remote Java Application Interface: @swo  (QITAG
GDB Server: | GDLinkGDBServer v
Exe Location: | CA\eclipse-rcp-2023-12-R-win32-x86_64\Tools\GDLinkGDBS erver\GDLinkGDBServer.exe | [Browse |
DB Server other options
Config Options | -device GD32E230C4T6 -speed 2000 -if swd |
Other Config:
[INen-stop mode (Note: Enable LiveExpression)
Download Config:
Sram Code Download Address: 0x20000000
Connect Configuration
[JConnect Under Reset
Revert Appl
Filter matched 11 of 52 items o B

@

[f)] Debug Configurations

Create, manage, and run configurations

O
X

CEREXBY -

Name: ‘GD32E230 GD ARM MCU Debug

[type fitter text

[E] C/C++ Application
[€] C/C++ Attach to Application
[E] C/C++ Postmortern Debugger
[E] C/C++ Remote Application

~ [} GDB General Debugging

[fi) GD32E230 GD ARM MCU Debug

[] GDB Hardware Debugging
Java Applet

Java Application

i Launch Group

[T Remote Java Application

Filter matched 11 of 52 items

Main ‘Debuggar‘stam‘p‘ SVD ‘

Initialization Settings

Initial reset Type:

Load Symbols and Executable
Load symbels
@® Use project binary: GD32E230.e1f

O Use file: [

| Workspace... | File system...

Symbols offset e [

Load executable
@® Use project binary: GD32E230.elf

(O Use file: ‘

| ‘ Workspace.. ‘ | File System...

Execwable ofiset e[|

Run/Restart Settings

Dlset progrom counerathent: ||

Set breakpoint at:

Do continue

Pre-run/Restart reset

Revert Apply

@
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[ Debug Configuratians m] X

Create, manage, and run configurations ﬁ-

[EeERX BT~ Name: | GD32E230 GD ARM MCU Debug |

Main | Debugger| Startup [ SVD
C/C++ Application SVD Path
C/C++ Attach to Application
/C++ Postmortem Debugger
C/C++ Remote Application
v [d1] GDB General Debugging
[fi] GD32E230 GD ARM MCU Debug
GDB Hardware Debugging
] Java Applet
Java Application
@ Launch Group
T Remote Java Application

‘type filter text

SVDPalh:‘D‘\GDEZEthddedBui\der_vl.SS_RE\\GB EmbeddedBuild lugi m.gigadevice.resources_1.0.0.202510281023\svd\GD32E23x.svd Browse

Revert Appl!
Filter matched 11 of 52 items. ever PPY

®

4.3. Debugging/Running

On the toolbar, choose Debug from the left drop-down menu. Choose Debug from launch mode
menu to start debugging.

Sr-AolaEe1ZR M EFE-O-w|vn®d e gissD

4.4. Resetting during Debugging

You can reset device during debugging by clicking the reset button on the toolbar.

|Fﬁ'“ J BB Dt S L [Cl-0- @&y - 8-GO Er0

4.5. Download & Erase

Click the Erase menu command to erase chip, and click the Download menu command to
download. You can see the output and results of the run command in the Console view.
The Download and Erase button functions in the two images below are consistent.
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5 Project Explorer i3
W -[EC S M aan

i MNew »
+3
> Go Into
L Open in New Window
>
5 Copy Ctrl+C
5 Paste Ctrl+V
> | & Delete Delete
| Source >
Mowe...
Rename... F2
&> Erase
@ Download

Migrate to GO Project

fxg Import.
&y Export.
Build Project

Clean Project

'] Refresh F5
Close Project
Close Unrelated Project

Build Configurations ]
Build Targets H
Index S
Q) PRunAs ¥
15 Debug As H
Profile As ¥
Team ]
Compare With H
Restore from Local History...
Configure »
Properties Alt+Enter

DBl a2 ii din|Cloda -8 -0 it -0~ i®EIEIE- D

Bl Console &2 |:: Problems|é|Tasks|E Properlies| 15k 5@ EC'*‘ a8~ =0

Gigadevice MCU Eclipse console

~
infermation: Start downloading...

information: Flash download address GxBSee2200
information: Flash download successful.

information: run successful.

4.6. Peripherals View

To monitor registers during debugging, you need to open the Peripherals View first. When the
MCU is halted, you can watch the peripheral register value.
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Select Window > Show View > Other menu command to start a new wizard, then expand the

Debug folder and select Peripherals View. Click Open.

M show View

type filter text

v (= Debug
@g Breakpoints

35 Debug

[i] Debug Shell

&l Debugger Console

' Disassembly

Executables

Expressions

Memory

Meadules
05 Resources

Peripherals View

o
0
[0 Memory Browser
)
£
O
1010

| n J Y

Open

Cancel

You can modify registers in the Peripherals View. Type a new value in the HEX Value column of
target register bits row, then press the Enter key to start the modification. If the modification is
successful, both the register bits and the register value will be refreshed. Otherwise, the
modification is invalid, which may be due to the peripheral clock is not enabled.

& Consale [}t Registers [[2] Problems | () Executables| (1) Debug Shell| @ Debugger Cansole | [ Memory | [ Peripherals View 3 | =0
Name Address HEX Value BINARY Value ~
> PMU
~ RCU
> CTLO Ox 40021000 0x 03037C83
> CFGO 0x 40021004 0x 001D000A
> INT 0x 40021008 0x 00000000
> APB2RST 0Ox 4002100C 0x 00000000
> APBIRST Ox 40021010 0x 00000000
v AHBEN Ox 40021014 0x 00000014
PFEN 0x0 0b 0
PCEN 0x0 0b 0
PBEN 0x0 0b0
PAEN 0x 0 0b0
CRCEN 0x0 obo
FMCSPEN 0x1 0b1
SRAMSPEN ox1 0b1
DMAEN 0x0 0b 0
> APB2EN 0x 40021018 0x 00000000
> APB1EN Ox 4002101C 0x 00000000 v
&) Console | i} Registers |[£] Problems | {3 Executables | [i] Debug Shell| G Debugger Console | [ Memory | [ Peripherals view 32 =
Name Address HEX Value BINARY Value A
> PMU
~ RCU
> CTO ‘0x 40021000 0Ox 03037C83
> CFGO ‘0x 40021004 0Ox 001D000A
> INT 0x 40021008 (Ox 00000000
> APB2RST 0x 4002100C 0x 00000000
> APBIRST 0x 40021010 0x 00000000
v AHBEN 0x 40021014 Ox 00400014
PCEN Ox 0 b0
PBEN 0x0 b0
PAEN 0x0 b0
CRCEN 0x0 obo
FMCSPEN Ox1 ob1
SRAMSPEN O 1 0b1
DMAEN 0x0 b0
> APB2EN 0x 40021018 0x 00000000
> APBIEN 0x 4002101C Ox 00000000 v

4.7. Live Expressions View
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This view supports real-time monitoring of expressions during debugging. You can add
expressions that need to be monitored in the view and set the monitoring time through the view

menu bar.

Note:

Only supports Live Expressions viewing during GD-Link debugging sessions

Select Window > Show View > Other menu command to start a new wizard, then expand the
Debug folder and select Live Expressions. Click Open.

ype filter text

(Y] Show View

» = General
» = CfC++
~ = Debug
9g Breakpoints
%5 Debug
E Debugger Console
[1] Debug Shell
&% Debug Sources
=2 Disassembly
0 Executables
&' Expressions
&4 Live Expressions
A Memons

Cancel

Before using Live Expressions Views, you need to enable Non-stop mode in the debug

configuration.

[@Y] Debug Configurations

Create. manage. and run configurations

CHeRX BT -

type filter text

w [c] C/C++ Application
[T 450.elf
[E] C/C++ Attach to Application
[E] C/C++ Postmortem Debugger
[E] C/C++ Remote Application
~ [fi] GDB General Debugging
@ 230LiveTest GD ARM MCU Debug
[E] GDB Hardware Debugging
Java Applet
Java Application
@ Launch Group
T Remote Java Application

Name: 230LiveTest GD ARM MCU Debug

Main | Debugger| Startup| SVD |

Debugger

Debugger: GD-Link

Core ID:  DxBF11477 Scan

GDB Server Setup

IP Address:  localhost

Port: 5099

Device: GD32E230CATE [ Code in RAM

Interface: Oswp  OITAG
GDB Server:  GDLinkGDBServer v

Exe Location: DASoftware\2023Eclipse\eclipse202312\Tools\GDLinkGDBServer\GDLinkGDBServer.exe Browse

GDB Server other options

Config Options -device GD32E230CBT6 -speed 2000 -if swd -

BRI
8 Non-stop mode (Note: Enable LiveExpression)
Revert Apply

Filter matched 12 of 20 items e BB
@
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Variables or expressions can be added to the view for monitoring, and the sampling time can be
changed through the Delay configuration.

Bin|buEN Lo @S | CO@ O ®S PrF-oFarD - |mi Q iR @
=0 Live Expressions X | % Expressions. =0
- Loelagfioon 2] remove Remove Al

Name Type Value
#* configure gystick */ A
systick_config(): €= parad int 54
EDs, USART and key */ @ parsd + 1 int 65
gd_eval led init(LEDI); ©: parad 22 int 128
3 9d_eval_led init(LEDZ): & Add new expression
84 gd_eval_led init (LED3);

gd_eval_com_init (EVAL_COM);
0d_eval_key_init (KEY_WAKEUE, KEY MODE_GEIO):

% series fizmware version: VEd.3d.:d", (uinti_t) (fw_ver >> 24), (Winté_t) (fw
RSTON_DEFINE */

/* print out the clock frequency of system,
printf("\r\nCK_s¥s is %", rcu_clock_freq_get (C}
printf("\r\nCK_AHB is %d", rcu_clock freq _get(Cl
q_get (CK_APB1));
_clock_freq_get (CK_APBZ)):

and APB2 */

printf ("\r\nCX

parak = 0;
wnile(1) {

103 parak ++;

104 delay lms(500):

105 ¥

e ¥

)5 #ifdef GD_ECLIPSE_GCC
)9/ retarget the C library printf function to the USART, in EClipse GCC environment */
nt _io_putehar(int cn)

usart_data_transmit (EVAL COM, (uintS_t) ch);
while(RESET == usarc_flag get (EVAL COM, USART FLAG TBE)):
114 return ch;

4.8. RTT Console View

This view supports real-time monitoring of RTT data during JLink debugging.
Note:
Only supports real-time RTT data viewing during JLink debugging sessions

Select Window > Show View > Other menu command to start a new wizard, then expand the
Debug folder and select RTT Console. Click Open.

M show View a X

type filter text

{3 Executables
9" Expressions
0 Memory
B, Modules
85 05 Resources
[[] Peripherals View
i Registers
||'f| RTT Console|
e Signals
25 Trace Control
{x)= Variables

> [= Help

¥ = lava

o lmmem Dermasertmm

The upper right corner of the view provides 'Start’, 'Stop', and 'Clear Console' functions for
controlling RTT monitoring and information printing.
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L&l mainc X = O ||[J RTT Console X | 5= Outline| @ Build Targets > u

& int main(void)

#ifdef _ FIRMWARE VERSION DEFINE
t32_t fw_ver = 0;

genaif

gd_eval_led init(
systick_config();

EDI1) ;

#ifdef _ FIRMWARE VERSION DEFINE
fu_ver = gd32f4xx_firmware version get():

printe("\;

series firmware version: Ved.sd.sd",
#endif ST

_©) (fw_ver >> 24), ¢

_©) (fw_ver >> 16},

SEGGER_RTT_Init();
SEGGER_RTT_printf (0,

while (1) (
SEGGER_RTT_SetTerminal (0):
SEGGER_RTT printf(d, "Channel
SEGGER_RTT_SetTerminal(1);
SEGGER_RTT printf (0, "Channel 1 Output
delay_Ims (1000):

0 Output Test\r\n");

Testir\an) ;

#ifdef GD_ECLIPSE GCC

©int _ io_putchar(int ch)

{
usart_data_transmit (EVAL_COMO, c_tem;
while (RESET — usart_flag_get (EVAL COMO, USART FLAG TBE)):
return ch;
[E2 Problems | £ Tasks [E Console X | ] Properties R %[5 b

ated> 450Test GD ARM MCU Debug [GDB General Debugging] J-Link (Terminated 20259/ 305 F4-4:52:52) [pid: 8028]
Read register 'Lr' (4 byces) from hardware: OxC30F0003

Read zegister 'pe' (4 bytes) from hazdwaze: 0xE6100008

Read register 'mpsr' (4 bytes) from hardware: 0X00
Read 4 bytes @ address 0x0S0010E6 (Data = Ox2BO0ESIE
Read 4 bytes @ address 0x03000FCZ (Data = Ox2690ETEC)
Reading 64 bytes @ address 0x20001140

GDB closed TCP/IP connestion (Socket 1004)

Restozing tazget state and closing J-Link connection...
Snutting down
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5. FAQs
5.1 Building

Q1: W515 compilation error.

A1.Check if it is a O Flash product, manually change the Id size.

= gd32w51x flashld X |
/* memory map */
MEMORY
{
FLASH (;FW)&:} : ORIGIN = 0x08000000, |LENGTH = 0K
EAM (m:} : ORIGIN = 0x20000000, LENGTH = 445K

}

Q2: Compilation prompts that .h file cannot be found, but the file exists in the project and can be
navigated to.

A2.This is caused by Windows system path length and compiler limitations. The file path may
be too long, exceeding the compiler's range. This can be avoided by changing the software folder
length or project path length.

5.2 Debugging

Q1: After connecting GD-Link V2 to the computer, the IDE does not detect GD-Link on Windows
10/Windows 11.

A1.0n Windows 10/Windows 11, first uninstall the GD-Link V2 device driver, then reconnect and
power cycle the GD-Link V2 device.

Q2: Breakpoints do not stop during debugging

A2.Check if the "Skip All Breakpoints" feature is enabled.

F.

% Breakpoints n K - H| = q~==D| i
® "= gd32g5x3 init.c [line: 86]
® "= gd32g5x3 init.c [line: BY]
® = gd32g5x3 initc [line: 110]
® "= gd32g5x3 init.c [line: 114]

1 | ® Breakpoints X > Sﬁ )| = || = q‘—jﬁl v § = 8
-] init.c [line: - :
a gd3295x3_!n!tc [|!ne 86l Skip All Breakpoints (Ctrl+Alt+B)
@ © gd32g5x3_initc [line: 89]
B @ gd32g5x3 initc [line: 110]
@ © gd32g5x3_initc [line: 114]

Q3: If the Debugger page prompts "Fail to read core ID"
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A3.Try using GD-Link Programmer to check if the GD-Link device serial number is correctly
recognized. If not, and your PC is running Windows 10 or 11, uninstall the driver in Device
Manager, then reconnect the device. Open GD-Link Programmer again to see if the serial number
is recognized. If it is, the issue is resolved. This method usually solves the problem.

Q4: When multiple CMSIS-DAP devices are connected to the computer and using OpenOCD and
GD-Link for debugging

A4.Add the GD-Link device serial number in the cfg file.

) N 031228?054’&

ornect GD-Linlk.

|=| openocd_gdlink.cfg

Gigalevice GD32F58x target

H oH K

adanter driver rmsis-dan

rmsis_dap serial 38312287@854E

source [find target/swj-dp.tcl]
source [find mem_helper.tcl]

Q5: GD-Link V1 does not require driver installation

A5.GD-Link V1 is driver-free. If V1 is not recognized by the PC, check if a driver has been
installed. In Device Manager, V1 should appear as shown below:

ICEF MEfER) RV RENH)
4= m | I Br & BX3

o TEEEME
= FIEOELH
i WO (COM 30 LPT)
¥ =
e
.
=
w b AR SE
i USE WA R
P USE mAEE
e USE SRAGEE
[l USE SRA SR
g USE S 2
Fep T HID SRS iR
oy 2 HID AT |
e = HI Dhﬂ?ﬂ'"?‘-‘!ﬁ i
A TR HID e e
- | s
B Microsoft Device Assocabion Root Enumerstor
B Micresef G5 RS 5EE
B Micreseft RRAS Root Enumerator
« [ oinien
P InteliR) Oynamic Application Loader Host Interface
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e & HID IRENEAFTEVIEE Bl
MR EIEA) BBV EEIH) 2 Eaes FEEE =i
e D HE B LX® _
= My WEHD TR AT Vg
> S THERESIER
> = FTENEAE
> @ B0 (CoM A LPT) BE(P)
> B N
. ;ﬂgﬁﬂ =EEHEEE ~
> [ ==
> H#E B
v AEEEAEE HID\VID_28E9&PID_068F\681539ABA58:180000
USE BAEE
USE EAEE
USB ENEE
USB & NEE
USB S aEE
|7 =e HD mensEEEvieE |
& HID tRER Eiienl=R
& HID tRENAPEShEE
& HID tRERAPEShaE
v 1 wiseE
B Microsoft Device Assodiation Root Enur
B Microsoft G5 =S R=R
B Microsoft RRAS Root Enumerator
v B siEal
P Intel(R) Dynamic Application Loader Ho! o

Q6: Expressions View Data Number Format Selection

A6.

1.To select the number format for a single Expression, right-click the Expression > Number

Format > choose the desired format.

2 B || Variables | % Expressions X | LD | =R K| E 0|
Expression Type Value
[v (= data int [5] 0x20000cB0 (Hex) I
- data[0] int Select Al CerltA
()= data[1] int |2 Copy Expressions Ctrl+C
()= data[2] int 3 Remove
- data[3] int & Remove Al
Lt Details [ Number Format Z > |
& Add Default Add Expression Group >
Decimal 3 Find.. Cer+F
B B & Add Watch Expression..
) Disable
Octel Enable
Restors To Preference Edit Watch Expression..
“%  Add Watchpoint (C/C++)...
&, Cast To Type..
1 Display As Array..
B Watch
|

()= Variables | Expressions X LB g X% it § = 0O

Expression Type Value

v (@ data int [51 0x20000c80 (Hex)
9= datal0] int 10
9= data[1] int 3

[ 0o dataf2] int 0xf (Hex)
()= data[3] int 7
(9= datald] int 12

op Add new expression

2.To select the number format for a all Expression, click the View Menu in the upper left corner >

Number Format > select the radix to display.

(0= Variables |7 Expressions X LB % %S :?l_ﬁ =]
Expression Type ) Layout b3
|V ds D Default Numnber Format >
()= data[0] int .
9= data[1] int ax‘ | 3 Java 2 >
9= datal2] int e 5
- data[3] int Octal
9= data[4] int Binary 2
& Ade new expression String

=]

(- Variables |3 Expressions EEEIEEE =N
Expression Type Value
v (@ data int [5] 0x2000080
- data[0] int Oxa
©3: data[1] int 0x3
[ o9 datal2] int Oaf
- data[3] int 0x7
9= data[d] int Oxc
&k Add new expression

5.3 Platform

Q1: Linux Ul show error.
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A1. The display mode of Linux systems needs to be switched to Xorg. For Ubuntu 22.04.2 LTS,
the display mode can be set as shown in the figure below. You can switch the display mode at
the bottom right corner of the password login interface.

Ubuntu

-« Ubuntuon Xorg

Q2: Linux gdb debugging error.

A2. If the gdb debugging function cannot be used normally and reports the error "./arm-none-
eabi-gdb: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No
such file or directory", please execute the following two commands to install libncurses5 online.

e sudo apt-get update
e sudo apt-get install libncurses5
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6. Revision history

Version

v1.5.5_Rel

Changes

1. Added the Download and Erase buttons synchronously to the toolbar.

2. Added the "Import file" option to the project's right-click menu for importing
folders or files into the project.

3. Updated the firmware library to the mid-2025 version.

4. Added the Startup Tab to the debug configuration for setting up debugging
options and commands.

5. Added GD-Link Live Expressions View.

6. Added J-Link RTT Console View.

7. Added support for J-Link JTAG protocol.

8. Template project added the F50x series support.

9. Optimized the GD project interface.

10. Repaired some bugs.
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